開發環境安裝與設定

電腦必須安裝先 Java 開發工具,才能編譯與執行 Java 程式。我們使用的 Java 的開發工具名稱為 Java SE Development Kit(簡稱 JDK),這份教材的程式練習需要 JDK 6 以上版本才能順利執行。

這份教材適用的 JDK 版本:

  • Java SE Development Kit 6
  • Java SE Development Kit 7

Java 版本區別方式

  • Java SE 1.2 至 1.4 都可以稱為 J2SE
  • Java SE 1.5 又稱 J2SE 5.0 或 Java SE 5,兩種都有人用
  • Java SE 1.6 普遍被稱為 Java SE 6
  • Java SE 7 也可稱為 Java SE 1.7,但已經比較少用

儘管 Java SE 的版本名稱慣例有歷經多次改變,但是在實際發行的 JDK 工具中,仍統一使用以下格式:

1.6.0_37

其中 1.6.0 指的就是 Java SE 6,而 37 為 Update 編號,也就是這個主要版本正式發佈後的第 37 更新版。Java Updates 更新通常代表著效能或安全性有所改善或程式問題被修正,建議開發者定期取得更新以維持開發環境保持在良好的狀態。

取得 Java 軟體

results matching ""

    No results matching ""